0

I'm getting the following error on starting GRASS using the GRASS 8.2.1 Docker container (source: docker pull mundialis/grass-py3-pdal:8.2.1-ubuntu):

    Launching <wxpython> GUI in the background, please wait...
    GRASS latlong_wgs84/PERMANENT:wxpython > 
    (wxgui.py:1277): dbind-WARNING **: 02:14:28.065: Couldn't connect to accessibility bus:       Failed to connect to socket /run/user/1000/at-spi/bus_0: No such file or directory
    wxnviz.py: No module named 'grass.lib.ogsf'

When the GRASS GUI appears I can see that under the 'File' menu the '3D image rendering (m.nviz.image)' is greyed out.

I get the same issue using the GRASS 7.8.7 GRASS Docker container (source: docker pull mundialis/grass-py3-pdal:7.8.7-ubuntu).

I have installed wxpython (without apparent error) within the Docker containers:

pip install --force-reinstall -v wxpython

The Docker run command I am using is this:

docker run -v /data/docker_tmp:/tmp:rw -v /tmp/.X11-unix:/tmp/.X11-unix -e uid=$(id -u) -e gid=$(id -g) -e DISPLAY=unix$DISPLAY --name grass821jammy -i -t mundialis/grass-py3-pdal:8.2.1-ubuntu /bin/bash

I suspect the issue is related to the Docker run command, as the problem is not evident with GRASS 7.8.7 installed directly on my laptop.

2
  • Have you tried the _wxgui images? hub.docker.com/r/mundialis/grass-py3-pdal/…
    – user2856
    Commented Jun 6, 2023 at 7:42
  • Thanks. I tried the two wxgui Docker images (8.3.0RC1 and 8.4dev) and they work fine, though there isn't a wxgui Docker image for the latest stable version as far as I can see.
    – Richard
    Commented Jun 7, 2023 at 13:24

1 Answer 1

1

The correct docker image with GUI support is this one: osgeo/grass-gis:releasebranch_8_3-ubuntu_wxgui. We are currently moving the docker images from "mundialis" to "OSGeo" dockerhub organization. The docker images overview page will reflect that soon.

To use and run it:

docker run -it --rm --volume="$(pwd)/:/data" \
 --volume="/tmp/.X11-unix:/tmp/.X11-unix:rw" \
 --env DISPLAY=$DISPLAY --device="/dev/dri/card0:/dev/dri/card0" \
 osgeo/grass-gis:releasebranch_8_3-ubuntu_wxgui grass --gui

which will start the GUI directly (otherwise, use bash to enter the container and start GRASS GIS with GUI from therein).

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.