1

I have a layer of 770 polyons (LWS) which are generally not aligned to OS Mastermap but mostly should be.

I am trying to use the Align Features tool to bring the LWS polygon boundaries that are less than 5m from an OS polygon boundary or line into alignment with it.

Currently I am testing on a single LWS polygon to test the process before attempting to run against the whole layer, but I am not getting the process to do anything.

Current process:

  1. Select LWS polygon to change manually
  2. Use select by location to select OS lines that are within 5m
  3. Open Align features geoprocessing tool, setting LWS layer as Input Feature, OS lines as Target Features and 5m as Search Distance
  4. Run button causes as series of progress bars to run and appears to complete successfully (green tick, Align Features completed message) but there is no change to the LWS polygon

ArcGIS Pro 2.9 Test polygon is a single part polygon Differences between boundaries for the LWS test polygon are small, about 0.01 m. Both layers are in same projection (British National Grid) but have different extents Topology in place for the two layers, with a Boundary Must be Covered By rule LWS layer is marked as editable in the Contents panel Additional column (AF_CONF: measuring confidence of fit) that should be created in LWS layer is not added

I had a similar issue recently with this tool but fewer polygons were involved so resolved it by hand.

Does anyone have any suggestions for how to get this to work?

3
  • What does LWS mean?
    – Hornbydd
    Jun 22, 2023 at 16:17
  • Effectively its my abbreviation for the layer name, standing for Local Wildlife Site.
    – gordon26b
    Jun 23, 2023 at 8:20
  • You should avoid or at least explain what you abbreviations mean as it is domain specific.
    – Hornbydd
    Jun 23, 2023 at 8:53

1 Answer 1

0

Just had a play with this tool as what you described sounded sensible, so why should it not work?

After reading the help file for the Align Features tool I took note of the statement "...The candidate shape has to be similar to the target shape..."

For my original test data I had accepted all the default settings and no matter what I did it did not align.

Test

Red test polygon fails to align

Exploring my data a little further I noted that the default is to set it as a polygon Z geometry. The layer I'm aligning to is not. So I copied my data, dropping the Z property (do that under the environment settings) and when I run the tool again I get the desired result.

Result

Green is the original, red is the result of the align tool.

So I suspect that you need to synchronise the data you want to align to OS MasterMap with it's geometry ZM aware properties.

1
  • Thank you. My layer had Z and M values, from the default settings when I created it. The OS layers had neither. I exported to a new feature class without Z or M. Ran Align Features again and it appears to have worked correctly. No visible differences and Topology Error Inspector shows no errors.
    – gordon26b
    Jun 23, 2023 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.