I have OpenStreetMap data and a database with the postgis extension, on a supercomputer (precisely Jean Zay, French cluster). In order to use JZ and install all the programs, packages etc I need on JZ, I use a conda environment.

I would like to populate my database using osm2pgsql (this is what I did on my local machine). Unfortunately, conda install -c conda-forge osm2pgsql shoots me the error PackagesNotFoundError: The following packages are not available from current channels.

I have tried anaconda instead of conda-forge, same result. Had no problem installing postgresql with this method. I haven't found any solution on SO nor on the manuals of conda and osm2pgsql. Given that this community uses osm2pgsql I think I have better chances at an answer than on StackOverflow.

How can I install osm2pgsql on a conda environment?

  • No-one has packaged it for conda anaconda.org/search?q=osm2pgsql (returns no results). Looks like you may have to build it from source unless you are able to run it in a Docker container.
    – user2856
    Jul 1 at 6:50

1 Answer 1


So, I have looked around and haven't found a way to get osm2pgsql on the distant machine that would not require me asking for more rights from the superusers. So what I did is build it locally, pg_dump, send it and then pg_restore on the distant machine. Worked ok although not the most efficient way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.