When using the arcpy.ga.JoinFeatures to write the joined feature to the memory workspace, I get error

ERROR 001409: Failed to write to the output location when writing output.


                           attribute_relationship='pk fk',

I've tried using r'in_memory\temp' and also setting the arcpy.env.workspace to 'memory' and passing the layer name only. All with the same error.

No issue on writing to a file geodatabase.

My gut is that it is an issue with the tools in geoanalyst which support multiprocessing through Spark - but i've not yet tried any other tools in the geoanalyst toolbox.

Unfortunately, due to my organsations convoluted licensing and support arrangements with ESRI, I am unable to raise this issue with ESRI or ask on their forums.

1 Answer 1


Per the Considerations for Geoanalytic Desktop tools help --

GeoAnalytics Desktop tools do not support the memory workspace.

  • Thanks. Imagine a world where ESRI start providing usefully informative error messages. ... Jul 26 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.