0

I was working with adding a new script to toolbox in QGIS but the script wouldn't show up there. Then when I tried again the Scripts tool has disappeared altogether. I have checked in settings and it does not give the option to add the scripts back in. I have attached some screenshots as an example. Has anyone experienced this before and know why it might occur? I have tried reinstalling and resetting to defaults but still have not had any luck.

enter image description here enter image description here

1 Answer 1

1

It's poor design/a bug with QGIS processing scripts. If you save a broken script, e.g. one that has a SyntaxError, none of the scripts will get loaded and the whole scripts toolbox disappears.

Either:

  • Use the Scripts menu to open the broken script and fix it, enter image description here

Or:

  • Go to your profile folder:

    enter image description here

    Open the "processing/scripts" folder and find the script you were working on so you can fix it.

    enter image description here

How you fix it depends on what the problem is, but I recommend you open it in a proper python IDE like PyCharm or Visual Studio Code so you can find issues.

Voila they're back!

enter image description here

1
  • It worked!! Thank you so much :)
    – Al110
    Jul 14, 2023 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.