0

The goal is to import coordinates (listed below) into QGIS. The coordinates are from Mission Planner, a program to set waypoints for drones, ... The position of the waypoints should be in Austria.

However, when I try importing them, they show up in the wrong position (either middle or outside of the map, or just in another country). The points however, show up in a correct relation to each other. I suspect its due to a wrong coordinate system. Interestingly, I managed to get the correct position out of luck, but can't reproduce it, even if I copy all coordinate systems in a new project.

I already tried to change a lot between coordinate systems to find the right one by luck. Another try was to set all coordinate systems to the same one, neither worked, the points just showed up in different locations sometimes.

What do I have to do when importing, to get the points to the correct location?

Settings of file import: enter image description here

Waypoint file (you can just copy and try to import it):

There should be tabs between all values after the first line

QGC WPL 110
0   1   0   16  0   0   0   0   47.7475769  15.5509329  959.516800  1
1   0   3   22  15.00000000 0.00000000  0.00000000  0.00000000  47.75101070 15.55260660 3000.000000 1
2   0   3   16  0.00000000  0.00000000  0.00000000  0.00000000  47.75274190 15.55123330 4000.000000 1
3   0   3   16  0.00000000  0.00000000  0.00000000  0.00000000  47.75121260 15.54852960 4000.000000 1
4   0   3   16  0.00000000  0.00000000  0.00000000  0.00000000  47.75210710 15.54059030 4000.000000 1
5   0   3   16  0.00000000  0.00000000  0.00000000  0.00000000  47.74916400 15.54389480 4000.000000 1

EDIT

Import with EPSG 4326: enter image description here

Import with the same coordinate system for everything: enter image description here

2
  • 5
    You need to choose the correct CRS, in which the points have been created. In your case EPSG 4326, if the table at the end is an example of data.
    – Erik
    Jul 18, 2023 at 14:23
  • @Erik When I set the coordinate system of the points to 4326 when importing, they show up in another place (see picture in edited post), when I set every system to 4326 (so the OSM layer, the project and the coordinates), they are in the middle of the map. What am I doing wrong? Jul 19, 2023 at 4:33

1 Answer 1

3

You mixed up the x- and y-values. The 15.5xxx-values are the X-values and the 47.75xxx values are the Y-values. So just assign the proper field in the import settings and stick to EPSG:4326.

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.