1

QGIS used to allow me to load a GPX file into Qfield through "add vector layer". Now there is an option to add a GPX dataset but my file will not add.

Here's what I've tried. First I converted a Gpkg file into a GPX file with by "save as" and "GPS_USE_EXTENSION" as 'yes':

enter image description here

It didn't add the file to the map, so I tried to re-add the GPX file into the project to check that it was rendering. It didn't work by trying to add the GPS file as a vector. I tried the GPS option. In the GPS option it asked me to choose waypoints, routes or tracks. I have tried all and none of them bring up the data. All give a data source error.

enter image description here

Thoughts?

1
  • 1
    If you have the data as gpkg why do you want to add it to qfield (or qgis) as gpx ?
    – J.R
    Commented May 26 at 16:28

1 Answer 1

1

Make sure your GPX file encoding is UTF-8. Open your GPX file in a text editor such as NotePad++. Under the Encoding menu, select UTF-8, then Save the file. enter image description here

or in Windows Powershell:

PS Get-Content .\mygpx.gpx | Set-Content -Encoding utf8 mygpx-utf8.gpx

Then try opening in QGIS again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.