3

When I add a dwg to ArcMap 9.3.1, the symbology is set, by default, to something the program calls "CAD unique entity values"(CAD Renderer?) - a combination of "Linetype", "Color" and "LineWt" fields. Is there any way to change the default so that any random DWG I load will be symbolized according to the "Layer" field (for example) and not those three field mentioned above?

2 Answers 2

1

You can load a CAD file in and style it up and create a layer file (.lyr) from a CAD feature class - this can be used on all the cad files (as long as they are standardised).

To take it a stage further you can create your Style in Style Manager for CAD features - the only disadvantage - each computer you work on requires that style to be loaded.

This can be automated if have many CAD files

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//00170000006n000000.htm

alt text

3
  • This sounds like a nice solution (the tool exists in 9.3.1), although I am having a hard time to make the CAD group layer "count as" a lyr file (the program doesn't recognize it as such).
    – jonatr
    Dec 23, 2010 at 8:35
  • It works. I made a model which uses the above tool five times (one for each type: annotation,point,polyline,polygon,multifeature). It is done by feeding a "sample" dwg in which the symbology is organized as you wish. The only defect is that you have to load the DWG and then load the types one after another (the DWG Group layer isn't recognized as a layer). Thanks anyway, it saves a lot of work.
    – jonatr
    Dec 23, 2010 at 14:40
  • Glad it helped, sorry thought you were on ArcGIS 10 - but you found your process
    – Mapperz
    Dec 23, 2010 at 16:09
1

I am pretty sure, that you will not be able to change this default setting (unless you can do this programmaticly). As I remember it, this way of handling and presenting CAD data in ArcGIS was introduced with version 9.3 and was one of the many new features.

1
  • see above, it does work.
    – Mapperz
    Dec 23, 2010 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.