0

I'm using a R2 Trimble antenna with a Windows 10 field-tablet to collect data on QField. However, I don't seem to be able to get the localisation working. It worked one day, and since then nothing.

The antenna works fine; I'm using the GNSS Status app on the tablet and set up the R2 correctly, as shown in this video (it's using a R1 but the idea is the same). I also read this part in the doc, which makes me wonder if the behavior of the GNSS antenna (which works using a bluetooth connection) can works with the Bluetooth-behavior of QField on Windows, which seems a bit peculiar:

Bluetooth support on Windows occurs through the virtual serial port automatically created by the operating system when it connects to the GNSS device.

What port I am supposed to use in the QField configuration? Is it the dedicated GNSS receiver one, or the Bluetooth outgoing one, that the R2 is using to stream NMEA data? I tried both (and some others) but each time it didn't seemed to work.

Just in case, a couple of variables:

  • Project used is in CRS 2154, QGIS version 3.28
  • QField is in version 2.8.4
  • GNSS Status tool app is some versions behind the last one (planning on updating this one soon but works perfectly otherwise).
1
  • Are you going to be using GNSS Status to feed real-time corrections (NTRIP corrections) to the R2?
    – Trams
    Commented Jul 24, 2023 at 22:23

2 Answers 2

0

Disclaimer: I've never used QField and I have not read the QField documentation. But I use Trimble receivers almost every day with Windows applications which want NMEA on a serial port.

Here's what I would do:

  1. Bluetooth Pair the Windows tablet with the R2.
  2. Open Settings / Devices and click on the "More Bluetooth Options" link - this will open a "Bluetooth Settings" dialog box
  3. Select the COM Ports tab - this will show the port numbers on your tablet which are assigned to the R2 (and other Bluetooth devices). Make a note of the port which is assigned to R2 xxxxxxxxx: Trimble 'COM2' - in my case this was COM99. You want to use 'COM2' for GField because GNSS Status uses 'COM1'.BT Settings dialog box
  4. Run GNSS Status and connect to the R2.
  5. Use NMEA Status to set up the NMEA sentences you want then apply these to Bluetooth SPP2GNSS Status NMEA ports
  6. Run QField and connect to the port for R2 'COM2' (in my case COM99)
  7. The R2 should remember the NMEA settings, so if you disconnect QField and GNSS Status from the R2 and power down the R2 then power up R2 again, QField should be able to reconnect to the SPP2 port without needing to use GNSS Status again (but you'll need GNSS Status if you are using that to supply NTRIP corrections to the R2).

You mention a "dedicated GNSS receiver" port - this is available for R1 with the latest 5.49 firmware and it was originally available on R2 but some R2 firmware update (around FW 5.42, I think) removed the GNSS port from R2, so use the SPP2.

0

It's me, I registered an account (the one that I used to post was unregistered), so I don't have the ability to check mark your response Trams.

Anyway, I did what you told me, and it worked... with some subtilities. When I mentionned the "dedicated GNSS receiver": when connecting an external device to QField, you have to enter its name, the type of connection (TCP/UDP/Serial Port) and the port itself. I choose Serial Port, and it left me with several options, among which there was a "u-block GNSS receiver" which was COM3, and I assumed it was the "dedicated GNSS receiver" that I read about somewhere in the QField Doc.

So, I did all the setup on GNSS Status, plus added some NMEA streams that I missed, then restarted the R2. However, when configuring QField, trying to set the port on COM10 (in my case, it was the COM2/Bluetooth SPP2), I got an error along the lines of "Location Device Error: Serial Port Error (Unknown Error)". As I thought there was a conflict with GNSS Status, I killed it with the task manager, then decided to restart the R2 and QField... and it worked !

So I tried some other things, and I found that:

  • R2 Bluetooth connection is not effective until QField is launched.
  • GNSS Status lost its ability to link with QField (it just says that it can't connect to the R2).
  • The QField connection works, because the "port" setting is left blank ! Apparently that is the tricky part of the QField-Windows Bluetooth connection, I did not need to set the port for the connection to work.

That's what I got from this experience. If anyone more knowledgeable than me has any explanation, I'll take it. In the meantime, everything works just fine ! Thank you !

2
  • Were you using a Trimble tablet? They often have u-Blox internal receiver, and it's often on COM3. From the port behaviour, it certainly sounds like you had a clash between GNSS Status and QField, but I don't know why GNSS Status would have connected to SPP2, it almost always uses SPP1 (or the dedicated GNSS port for R1). When you Apply NMEA settings in GNSS status, it shows you what port is in use. I'm happy it works - don't change any settings and hopefully it will keep on working!
    – Trams
    Commented Jul 25, 2023 at 21:23
  • Nope, not a Trimble tablet but a Handheld one! Yes that's strange, when I set up the R2 with GNSS Status it did give me the same windows that you posted with SPP1 "connected", so I choose SSP2. However, when I tried to connect the corresponding COM on QField, I got the error. I wonder if QField is actually "hijacking" the bluetooth connection when it detects the NMEA streaming, therefore ignoring the port used and not needing one in its setup. Well, it works now, only problem is when we'll need to reconfigure the R2 but that's another problem.
    – Phyllerock
    Commented Jul 26, 2023 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.