0

I've read many posts with similar issues, but not exactly the same. I have QGIS installed on Linux Mint Vanessa and I want to update to the newest version as the repository version is old, so I want to update to QGIS 3.32.

I've followed the instructions,and I've tried many different changes to try to get my system to update. I've downloaded the key using

sudo mkdir -m755 -p /etc/apt/keyrings  # not needed since apt version 2.4.0 like Debian 12 and Ubuntu 22 or newer
sudo wget -O /etc/apt/keyrings/qgis-archive-keyring.gpg https://download.qgis.org/downloads/qgis-archive-keyring.gpg

My current /etc/apt/qgis.sources.d list is:

Types: deb deb-src
URIs: https://qgis.org/debian/
Suites: vanessa
Architectures: amd64
Components: main
Signed-By: /etc/apt/keyrings/qgis-archive-keyring.gpg

I've tried changing Debian to Ubuntu, as well as Vanessa to Focal, Jammy, and the other options. When I run sudo apt install qgis I get a bunch of dependency issues so that doesn't work. I've also went into Software Sources and added a deb file, that didn't seem to do anything either. Right now I have deb https://qgis.org/ubuntu vanessa main

What am I missing?

I don't understand the process completely.

0

1 Answer 1

2

It sounds like you have run the following command to install the signing key correctly as per the download instructions:

sudo wget -O /etc/apt/keyrings/qgis-archive-keyring.gpg https://download.qgis.org/downloads/qgis-archive-keyring.gpg

Now run:

sudo nano /etc/apt/sources.list.d/qgis.sources

And make sure it contains the following:

Types: deb deb-src
URIs: https://qgis.org/debian
Suites: jammy
Architectures: amd64
Components: main
Signed-By: /etc/apt/keyrings/qgis-archive-keyring.gpg

If it doesn't, then either

  • delete the contents (ctrl-k a few times) or
  • exit nano (ctrl-x), delete the file (sudo rm /etc/apt/sources.list.d/qgis.sources) and reopen it (sudo nano /etc/apt/sources.list.d/qgis.sources)

And then copy and paste the above in (ctrl-shift-v will paste in the terminal). Make sure you copy the above after you use ctrl-k in nano.

Notes:

  • Undo any changes you've made using Software Sources
  • Your distribution should be jammy not vanessa as Linux Mint 21 is based on Ubuntu 22.04. You can check via the terminal command cat /etc/os-release and look for UBUNTU_CODENAME=
  • If you've got a /etc/apt/qgis.sources.d file you've done something wrong and should delete it. The file should be /etc/apt/sources.list.d/qgis.sources
  • It doesn't matter if you have URIs: https://qgis.org/debian or URIs: https://qgis.org/ubuntu in qgis.sources
2
  • I have done that and little variations several times, and still I am only able to get QGIS 3.22
    – DrewGIS
    Jul 29, 2023 at 21:45
  • I just installed Mint 21 Vanessa (in a VM), followed the instructions and got QGIS 3.32 without any problem. Make sure you have completely undone any changes you made. Particularly through software sources or any PPA/UbuntuGIS repos that you may have tried.
    – user2856
    Aug 1, 2023 at 3:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.