5

When ever I run a batch process in QGIS, the processing will stop at a seemingly random step. It does not let me cancel the process and no error is reported. However, if I start the batch process again from the file it stopped at, it usually completes successfully. This is very frustrating and happens with any process I run as a batch process. I have updated to 3.32.1 from 3.30 and still get the same problem enter image description here

3
  • 4
    Have you checked Log messages if there are any clues to why? View - Panels - Log Messages
    – BERA
    Aug 3, 2023 at 5:17
  • 1
    Try to process only one file/layer, does it work?
    – GforGIS
    Aug 3, 2023 at 8:59
  • 4
    There's no way anyone can answer this without more detail from you. My first check would be to see whether you are reading from and writing to the same file and there's some sort of file lock or conflict. Aug 4, 2023 at 0:18

3 Answers 3

2

If you close the batch processing window and minimize QGIS window, it happens less frequently. I can follow the progress by checking the folder with the generated output. I hope you have a way to check the progress with QGIS window minimized.

3.28 Long-term release on Windows here.

Edit: Running the same script in batch on Ubuntu in VM runs without issues. You can give it a try.

0

I've been having this issue since 3.22, it happens every time I run a Clip batch process. It is still an issue in 3.28 LTR.

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Aug 25, 2023 at 15:39
0

Unfortunately this appears to be a documented issue that occurs on windows machines. https://github.com/qgis/QGIS/issues/53806

A comment in the bug report provides a good way to restart the batch process: "As a workaround, you can try to close qgis, a popup will open, click yes to cancel pending tasks, qgis should remain open, hit run again and it may finish this time." https://github.com/qgis/QGIS/issues/53806#issuecomment-1635944944

Because it only seems to occur on QGIS on widows running a linux version of QGIS on WSL2 (Windows Subsystem for Linux) should circumvent the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.