1

I have a geodatabase file to update with FME Desktop : some features must be updated, et some new features must be inserted in that geodatabase file. Those features are polygons with several attributes.

First in my script, I read the geodatabase file. Then I change some values and create new ones.

Finally, I use a "Esri Geodatabase (File Geodb)" writer to update former data and insert new data at the same time. I chose feature opeartion "upsert" and table handling "create if needed".

When I open the resulting "updated" gdb file in Arcgis Pro, I can see the updated data and... only part of the new features. There are several of them missing ! But why ?

Here is what I should have : what i should have

And here is what I get : what i get

Am I doing something wrong ? Is there a way to correct this ?

1 Answer 1

2

I have already encountered this issue; it was due to excessive/duplicate nodes in some of the polygons. Check even the "full" polygons, sometime the missing features change with the scale or the position on the screen, like a display bug.

2
  • Indeed, when using a Geometry Validator, those features failed the validation. They have a "duplicated rings" issue. Is there a way to repair this in FME ? Commented Aug 3, 2023 at 14:30
  • I used a Deagregator and used a sampler to keep only the first polygon extracted. Thanks ! Commented Aug 3, 2023 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.