0

I am working with QGIS and QField Cloud for a while now and despite having to regularly solve sync issues, I'm quite happy with QFieldCloud for my purposes (collecting data in the field).

But now I encountered a sync problem for which I can't find any solution despite having tried every possible sync setting in QGIS and QField and searched the entire internet:

Every time I create a new layer (e.g. a vector layer) and sync it to QFieldCloud, the layer is marked as "read-only" after updating the app. The layer is stored in the usual QField Cloud folder on my desktop computer where all other editable layers are stored, too. In Project Properties - Data Sources, all layers are set as "Identifiable" and "Searchable", no layer is set as "Read-only". The layers I want to edit while in the field are set to "Offline Editing" in the QField Properties - Action tab.

In order to identify the error, I configured older layers as "Read-only" - after syncing, they were correctly marked as "Read-only" in the app. Switching this setting back also worked. I also recreated several new layers, reinstalled the QField app and synced the entire project again, but the problem keeps persisting: Newly added layers remain read-only despite configured differently.

Any ideas on what is wrong?

I am using QGIS LTR version 3.28.9 and QField 2.8.3

1 Answer 1

0

I encountered the same thing and discovered that the problem was the file type : new shapefile layers showed as "read only" when uploaded in to QField. Solved the problem by adding new Geopackage layers instead of shapefiles.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.