enter image description here

The visualisation in the attribute table is different for fields with the same data type (some are greyed out and the values have different positions)

Any suggestions?

  • 2
    Do you have a join on your layer ?
    – J.R
    Aug 29 at 10:11

1 Answer 1


You can right click on the layer to open its properties and go to the Attribute Form tab.

editable will enable/disable (and grey out) the field.
Type range will let you "scroll" through numerical values and will right-align the number.
Type Text edit will let your type a value and left-align it.

enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.