0

I want to create a map with different data. One layer is a WMS layer with the address: https://geodienste.sachsen.de/wms_geosn_flurstuecke/guest?

This layer contains parcels and the corresponding numbers in Saxony. If I create a print layout everything is fine, all parcels are correctly labeled. But as soon as I export the map, no matter what format, individual parcels are labeled multiple times. What could be the reason for this? I don't have any other layers in the project from which the labeling could come.

print layout enter image description here

pdf export enter image description here

I use the QGIS version 3.22.16 LTR

2
  • Looks like the pdf is using tiles
    – Ian Turton
    Sep 8, 2023 at 9:57
  • can I change anything about it via QGIS?
    – joe_gerner
    Sep 8, 2023 at 11:39

3 Answers 3

2

To disable tiled raster layer exports you have to scroll to the bottom of the PDF Export Options dialog and activate the „Disable tiled raster layer exports“ checkbox:

enter image description here

4
  • unfortunately the setting does not solve the problem
    – joe_gerner
    Sep 11, 2023 at 11:15
  • @joe_gerner I have to confirm your findings, I get duplicated parcel numbers as well. Maybe there is a problem with the WMS service when using higher DPI settings?
    – christoph
    Sep 12, 2023 at 14:30
  • @joe_gerner that's definitely a problem with QGIS. When you use the Developer Tools (press F12 in main window) you will see that QGIS is fetching multiple images during PDF export and combines the images before writing to the PDF file. You could post this here: github.com/qgis/QGIS/issues
    – christoph
    Sep 27, 2023 at 15:44
  • This problem already exists for a long time: lists.fossgis.de/pipermail/fossgis-talk-liste/2017-February/…
    – christoph
    Sep 27, 2023 at 15:57
0

As this problem seems to be very old and has no solution yet, I would suggest using MapProxy to fetch the tiles if you need it often. MapProxy has settings to prevent duplicate labels: https://mapproxy.org/docs/1.13.0/labeling.html

0

I believe one way to do this is by setting a fixed reference scale in your WMS layer.

You can do this by going to layer properties, go to the "Representation" tab, and check the "Fixed Reference Scale" option, and play woth the actual reference scale of the layer until it prints as desired. The reason this isn't playing nice is because the server and not you are controlling what prints, probably because it's got symbology and scale info built in that you don't have access to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.