I have a FileGeodatabase in ArcGIS 10.0 with a feature dataset and five feature classes (3 polygon shapes, 1 line shape, 1 point shape).

I'm trying to create a topology to verify some vectors. Rightclicking Feature Dataset > New... > Topology.

I'm getting the following error message in ArcCatalog:

ArcCatalog cannot create topology. The selected feature dataset does not contain any feature classes which can participate in a topology.

Browsing the internet for the error message, I found this tech article by ESRI. It tells the following:

There are several reasons for a feature class to be excluded from participating in a topology:

  • The feature class already participates in a topology or geometric network.
  • The feature class is an annotation or dimension feature class.
  • The feature class is registered as versioned.

I'm not quite sure what that means. There is no other topology or geometric network as far as I can see. What is an annotation or dimension feature class? The classes are all X;Y-coordinates only (2D). What is a versioned or registerd feature class?

I've tried checking all classes properties for something that sounds like that.

This answer to a similar question suggests to unregister the feature classes. But how?

  • Are your feature classes residing within the feature dataset? Jan 10, 2013 at 10:34
  • @Arabella yes. 5 classes within 1 dataset.
    – q9f
    Jan 10, 2013 at 15:38
  • 1
    I can see this also being affected by bad geometry, you might want to run 'Repair Geometry' across each of those layers to ensure that you don't have any issues.
    – D.E.Wright
    Jan 10, 2013 at 15:49
  • If you are using a file geodatabase then your feature class cannot be registered as versioned. help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//…
    – Jamie
    Jan 10, 2013 at 15:52
  • Damn, a buddy told me to refresh the feature dataset - voila: There was already a topology existing, but it was not displayed... a bug I guess.
    – q9f
    Jan 10, 2013 at 18:30

2 Answers 2


My guess is your going to want one layer, vector features, no points. No crossing line situations, overlapping lines, points, polygons. Try merging layers. What type of feature are you creating a network from, streets? Do your points have an association with the streets, Do your polygons reference the features they contain or visa versa in the tables? You might need to clean up the tables and data through quality processes and processes to make all associations clean. Have you defined a logic process model for what you are trying to achieve. I think asking the right questions sometimes help arrive at the correct answers for problems. You are trying to associate feature in a single layer otherwise a process would have to run accross layers to create an association which is an added layer of complexity and would have to be programaticaly achieved within the SQL.


It's one of these minor bugs in ArcGIS.

Refreshing the database view solved that issue: Right-click Feature Dataset > Refresh. A hidden existing topology was not displayed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.