I'm trying to build a model that after a bunch of processing exports the raster attributes table to an excel file. To do this, I figure I need to first use the "Export table" tool, followed by the "Table to Excel" tool. When I do this outside of ModelBuilder, it works perfectly, but when I add the same steps to my model, for some reason the "export table" tool only includes the first digit of a number in its output. For example, this is the original raster attributes table:

raster attributes table

and here is the same table after it has been run through the model with with "Export table" tool:

attributes table after "export table" in the model

What I have tried:

  • Changing the Fields setting in the "export table" tool, including the Properties>type settings to ensure the numbers were output in long type (not that I thought this would work as the default settings of the tool are the same inside and outside of ModelBuilder)
  • Using the deprecated "Table to Table" tool, but this results in the same behaviour

Does anyone know what is happening here and how I can fix it? Any work-arounds?

  • 2
    Copy rows tool?
    – FelixIP
    Sep 20 at 23:26
  • @FelixIP This worked, thank you! If you post as an answer I can mark as accepted.
    – IA_arcGIS
    Sep 21 at 0:57
  • 2
    Self-answer is Ok, do it please. Yes, PRO is still very raw
    – FelixIP
    Sep 21 at 2:03

1 Answer 1


Using the copy rows tool solved the problem in ModelBuilder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.