I want to disable word wrapping but I find no option to. I have made the legend box as wide as it should be. When the label text font size is small, it is on one line, but when I increase the font size then it wraps into 2 lines despite there being space.

2 Answers 2


From the ESRI help page

  1. In the Contents pane, right-click the legend and click Properties to open the Element pane. Be sure to click the legend element, not a legend item. Legend items have different properties.
  2. In the Element pane, select the tab containing the properties you want to change.
    • Options tab Options :Turn on or off the legend title, and adjust the title text.
    • Legend Arrangement Options tab : Set fitting strategy, word wrapping, and spacing properties.
    • Display tab : Set border, background, and shadow properties.
    • Placement tab : Set size, position, and rotation properties for the entire legend.
  3. Adjust the properties as desired.

As you see the word wrapping setting is in the Legend Arrangement Options tab (it's the second icon with two arrow and two small square), make sure to set a value appropriate for your text length here.


In the content pane on the left side, right click on the legend and click "Convert to Graphics". This will give you more fine grained control over how the legend looks. This fixed my issue and made the layer label one line again. Here is a YouTube video for a better explanation:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.