I have read a number of posts and tutorials, even the QGIS manual on snapping. I set the snapping options under settings>snapping options; selecting the two layers that I would like snapping on, setting the mode to vertex, the tolerance of 0.00002 map units and checked avoid int. and enable topological editing.

I moved the on polygon on layer one, grabbing the approximate vertex to the adjoining approximate vertex on layer two. at a scale of 1:500 it looks as though it snaps correctly, but when I zoom in to a scale of say 1:1 they are not aligned properly. Am I missing something or attempting to be to accurate?

Thanks for the input.

  • What are you map units? 0.00002 seems really small
    – Nathan W
    Jan 11, 2013 at 13:24

2 Answers 2


The tolerance of 0.00002 map units is obviously wrong. I have set my snapping tolerance to 10 pixels, which means that a point is snapped to an existing point if it comes nearer than 10 pixels.

With the small tolerance you set you avoid snapping in most cases, unless you are working in a scale of 50.000:1 (not 1:50000!).

  • Ok, so I changed it to 10 pixels and moved the polygon again. at a scale of 1:500 it looks good, but when zoomed into say 100000:1 its off. I know a map will never be viewed at that scale, but I guess its a question of accuracy. I came form the CAD world, where accuracy is vital.
    – LandArch
    Jan 11, 2013 at 14:10
  • 4
    100000:1 is pretty dam small. I very much doubt you would need that level of precision in a GIS system. QGIS might not render accurately at that level too.
    – Nathan W
    Jan 11, 2013 at 14:58
  • Best way to test the snapping is to move the node. With topological editing on, both polygon nodes should move together (You can Undo the move afterwards).
    – AndreJ
    Jan 11, 2013 at 15:09
  • This discusses the parameters of the OP's problem, but probably hasn't been much help to the 3,500+ people who have clicked to the page "How does snapping in QGIS work?". Some additional info would be useful.
    – geotheory
    Aug 12, 2014 at 12:14

I was able to solve the snapping problem by going to Settings, Snapping Options; set the ff: Layer selection---All Visible Layers Snap to------Vertex Tolerance----3 Select map Units.

What this does is that when a node comes within the snapping tolerance, it gets snapped on the nearby vertex.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.