0

When I import a DWG, into QGIS, sent by an architect it is not located in the correct place. I'm using EPSG:27700

If I edit the file in CAD and move the drawing by a factor of 1000, so 415287786.3,572013886.6 is moved to 415287.7863,572013.8866 the drawing then locates in the correct place when imported.

This is a repeating problem as architects are referencing to a mm grid and not a m grid in their CAD software.

How can I smooth my process of importing their drawings so that this translates properly?

2
  • 1
    What GIS software are you using?
    – Mapperz
    Commented Nov 6, 2023 at 20:51
  • @Mapperz QGIS - sorry should have said Commented Nov 6, 2023 at 20:56

1 Answer 1

0

You can do this by using a custom coordinate system (CRS) for these layers.

Select option Custom projections from the Settings-menu.

Adding custom projection

There:

  1. Add a new CRS (+ button)
  2. Enter a relevant name, say: BNGmm
  3. Select your original CRS (button next to the "Validate" button)
  4. Change the representation to "Proj string" (Using WKT was too hard for me)
  5. In the Parameters, change the units from m to mm
  6. Test the new CRS by entering a northing and easting (in WGS84) and press "Calculate". This should give you the coordinate in your new CRS.
  7. Save your new CRS. Note: I got an error trying to save my new CRS. This was because QGIS added an empty CRS by default. I had to delete this empty entry before saving. (- button)

Apply this new CRS to the DWG layer(s) when/after you import them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.