-1

I have a small table of wells with just a name, lat, lon, and geometry in an Esri Shapefile. I am putting them into a PostGIS database and it works well, so I added an arbitrary well_id as a serial so they'd have a unique numeric id for the Primary Key.

The picture here works, but the well_id attribute is red, and I'm not sure why, or if there is a way in FME to make it not red.

Did I set this up wrong or is this expected behavior in FME when adding a serial that is not in the source shapefile and going to PostGIS?

Feature Type - User Attribute Details

2

1 Answer 1

1

You have not done anything wrong. This means that FME does not know where to get the data from and save it into that attribute. If you do know however, you could just connect the attribute manually by dragging or creating a new connector from the source data into that writer, or simply renaming the attribute in the writer to match the original attribute name in the reader.

Alternatively, you could use the "Automatic" or "Dynamic" options to get the attribute name updated automatically.

In the example below, the original data are in a different language than the destination data.

enter image description here

Just drag a connector as shown below:

enter image description here

Once connected:

enter image description here

The red color will be gone:

enter image description here

Other options will be to use the AttributeManager or AttributeRenamer transformers to rename the attribute names

enter image description here

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.