0

GIS program manager here. I am experiencing a serious problem. It occurs when starting new projects in ArcGIS Pro from a template which includes our "program toolbox" (aka Default.tbx) located at "O:\GIS\PROGRAM_NAME\Tool\Toolbox\Default.tbx". The problem also occurs when starting a new project with an empty map (not using a template) if the program toolbox is set to be automatically included in new projects in the software options (settings > options > application > general > create projects).

What happens is that: (1) Default.tbx is renamed to match the project name chosen by the user. For example, if the project name chosen is "MyProject22", then Default.tbx will be renamed MyProject12.tbx. (2) In addition to this, a new toolbox called "Default.tbx" is created, but this toolbox is empty. As you might imagine this creates problems, because every project will now reference the new, empty Default.tbx, and our program-specific tools will not be found. Additionally, this clutters up the program toolbox folder (see path in image) with empty "junk" toolboxes.

Note that my team is working on ArcGIS Pro 3.1 installed on Amazon Workspaces virtual desktop. We link to a license server to access floating licenses for ArcGIS Pro.

We have tried changing the name of "Default.tbx" to something else like "ProgramName.tbx", but the problem still occurs. We have also tried this using an ArcGIS Pro toolbox (.atbx extension) and the problem still occurs. Note that similar behavior is not observed with our program geodatabase at "O:\GIS\PROGRAM_NAME\Data\Default.gdb"

*Note: some names anonymized due to corporate policy and standing confidentiality agreements.

Example of settings for program options as described in the textExample of files created and files renamed as a result of the problem described in the text

3
  • 1
    Have you contacted Esri Tech Support?
    – Vince
    Commented Dec 1, 2023 at 22:46
  • @Vince We are in an experience gathering / documentation phase and plan to reach out to our corporate relationship manager at ESRI when we have completed this phase.
    – jpartsch
    Commented Dec 1, 2023 at 22:53
  • As PolyGeo shared below try renaming/upgrading to atbx, also besides that try setting the toolbox in the catalog-->add favorite. Commented Dec 2, 2023 at 13:43

2 Answers 2

2

Irrespective of anything else that may be happening in your configuration, I think it is a mistake for you to name your “program toolbox” as Default.tbx or Default.atbx because that is the name ArcGIS Pro uses for the toolbox it creates when creating a project without a template.

1
  • I'm sorry if it wasn't clear from my description, but a renamed toolbox "Program_Name.tbx" was tested, and having this toolbox as the one referenced in software settings for new projects did not prevent the problematic behavior from occurring, so PolyGeo's suggestion is not a complete solution to the problem, however their suggestion of NOT naming a toolbox "Default" as best practice is noted.
    – jpartsch
    Commented Dec 5, 2023 at 23:11
0

PolyGeo's suggestion, though it did not solve my problem, pointed me in the direction of the solution. I realized I had not tested BOTH renaming the toolbox and converting it to a .ATBX toolbox in combination - I had only tested each of these changes separately. Actually, when I brought this up to my team, a team member told me she had already tested such a solution in her sandbox area, and it seemed to work. I applied the same approach to our main program data server and it seems to have worked.

The solution appears to be: do not name a toolbox "Default" AND do not use the old .tbx format, instead use only .atbx format.

In summary: "Default.tbx" produces the buggy behavior, while "ProgramName_Default.atbx" does not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.