0

I am working on a mapping project that consists of downloading USGS Lidar data. Due to the volume of the data I have been storing the '.tif' files on a 1T external drive called 'GIS Drive'. For several days I have been downloading the files from the internet to my computer, moving them onto the drive, then loading them into the QGIS project. After that, I was reprojecting the data to a different coordinate system and outputting them directly into a folder on the same drive with no issues.

Today while working, I successfully did one batch of reprojecting and without quitting the program or making any changes that I am aware of the second batch of reprojecting gave me the error "Invalid Data Source: /Volumes/GIS Drive/DEM Erie Coast/Reprojected 1 m DEM/68y468_1_r.tif is not a valid or recognized data source."

Now, when I try and load any data that I downloaded after I started getting that error message to the project, I get the same error message about the drive being an "Invalid Data Source". Data that I had previously downloaded and reprojected are all fine. The .qgz fie for the project itself is stored on that drive and QGIS will successfully open it, just anything new I try and do is denied.

I tried loading files that I reprojected on my computer to the drive and then resetting the data source and that gave me the same "Invalid Data Source" message.

I've tried ejecting the hard drive and re-inserting it, I restarted my computer, I uploaded QGIS to the latest version, and I've tried using new data from the external drive all with no success. Everything I had on the drive prior to today can be successfully loaded into projects, but everything else is deemed "Invalid".

Attached are some images that might be helpful. Any advice?

Older files have the data source that is being called invalid for newer files

The project itself is stored on the drive that is now being called invalid

Drive properties on my desktop

Drive properties in QGIS

2
  • Just to note the drive is not the data source. In this case, data source of a layer is the file where its data comes from. So the files are invalid for some reason. If a file from another drive is a valid data source, and it turns to be invalid when copied to the drive, so something in the copy process failed. If not, you need to reproduce steps (reprojection, if not download) to see which process is creating an invalid raster file. Commented Dec 6, 2023 at 2:25
  • Please check if the files was completely downloaded. The file is probably corrupt.
    – webrian
    Commented Dec 6, 2023 at 7:40

1 Answer 1

1

I'd say its a hardware issue with the drive. Try copying any file (maybe a Word document) to the drive and read it with a program other than QGIS. If that also fails you can be sure the problem is not QGIS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.