0

I've downloaded a kml file from here: https://gbank.gsj.jp/madas/map/index.html to look at some aerial photography. I've clicked 'kml' and it downloads a kml file. When I drag this into QGIS it displays the shapefile of the image boundaries, and raster that doesn't display anything.

I then opened the kml file using notepad++ and can then view the metadata and what apears to be a WMS link. When I create a new WMS link in QGIS and import this url: https://aster.geogrid.org/atlm/2309121819382309139003?service=wms&request=getmap&version=1.3.0&layers=default&crs=epsg:4326&format=image/png&transparent=true

it loads the layer into QGIS but nothing displays. I've tried all the different options before clicking 'load' after connecting the WMS link, and tried WFS.

Why can't I see the image?

Edit: I get this error on the raster file (invisible) that imports when I drag the kml file in: IReadBlock failed at X offset 0, Y offset 0: GDALWMS: Unable to download block 0, 0. URL: HTTP status code: 0, error: (null). Add the HTTP status code to to ignore this error (see http://www.gdal.org/frmt_wms.html).,IReadBlock failed at X offset 0, Y offset 0: GDALWMS: Unable to download block 0, 0. URL: HTTP status code: 0, error: (null). Add the HTTP status code to to ignore this error (see http://www.gdal.org/frmt_wms.html). IReadBlock failed at X offset 0, Y offset 0: GDALWMS: Unable to download block 0, 0. URL: HTTP status code: 0, error: (null). Add the HTTP status code to to ignore this error (see http://www.gdal.org/frmt_wms.html).

1
  • https://aster.geogrid.org/atlm/2309121819382309139003?service=wms&request=getmap&version=1.3.0&layers=default&crs=epsg:4326&format=image/png&transparent=true doesn't supply sufficient information to fetch a map image; you are missing several parameters, like bounding box, width and height. Case is also wrong for some of the parameter values.
    – nmtoken
    Jan 2 at 18:27

1 Answer 1

1

The server is somehow misconfigured. The GetMap URL that is shows in the GetCapabilities https://aster.geogrid.org/atlm/2309121819382309139003?service=WMS&version=1.3.0&request=GetCapabilities does not work. Bypass that in the QGIS connection configuration

enter image description here

This setting makes it work for me

enter image description here

You have included too much to the URL of the WMS connection. I am not sure if it makes trouble, but this is all you need: https://aster.geogrid.org/atlm/2309121819382309139003

1
  • Thank you so much! I got it now to display. Dec 15, 2023 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.