0

I have a composition of several layers (resolution 30 m). Now I'm trying to combine them into one using the Build Virtual Raster tool (or is another tool needed here?) to then save it as JPG.

The original composition looks like this:

enter image description here

The order of the layers is as follows:

enter image description here

If I arrange the layers like this (reverse):

enter image description here

then the resulting layer looks like this:

enter image description here

And if I arrange the layers like this:

enter image description here

then the new layer will already look like this:

enter image description here

Both layers are very far from the desired layer.

Apparently, QGIS 3.34.1 combines layers randomly, and I need a strictly defined order, as in the first image.

How can I specify the exact order of the layers in the Build Virtual Raster tool?

P.S. Advanced settings I have (Windows; these are all settings for Build Virtual Raster tool):

enter image description here

P.P.S. I realized that the reason is that one of the layers has a different coordinate system (32644 instead of 32643 for the rest, because different time zones), therefore, the order of the layers is violated when creating a virtual raster (the algorithm all leads to a single coordinate system).

If I change the coordinate system of this layer to 32643, then the layer will shift to a completely different place, which is unacceptable. Therefore, the problem here is the following: creating a virtual raster as it is, regardless of their coordinate system, if possible.

3
  • You could try enabling the option to add an alpha band, in the Build Virtual Raster tool's advanced parameters, to get rid of the white space. Alternatively, you can try placing the input rasters into separate bands (another one of the tool's parameters), and rearranging the bands in the output layer. Or both...
    – Andre Geo
    Jan 4 at 14:55
  • @AndreGeo I tried the first 2 methods separately - nothing has changed, and if both are at the same time, it generally gives an error: ERROR 6: -The option to add an alpha version is incompatible with -separate.
    – senek
    Jan 5 at 18:56
  • In general, the question remains actual. Maybe another tool is needed here, rather than Build Virtual Raster?
    – senek
    Jan 5 at 18:57

1 Answer 1

2

They are merged by the order you have arranged (your third screenshot), I dont think that is the problem.

You can try modifying the Advanced parameters of Build Virtual Raster.

I have three rasters to merge and the values that should be transparent have the value 0:

enter image description here

So I set Nodata value.. to 0 in Advanced parameters: enter image description here

To get the desired result: enter image description here

1
  • I did it this way. Unfortunately, it didn't work in my case...
    – senek
    Jan 5 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.