1

I am trying to install the r.clip addon in GRASS 8.2 in Ubuntu 22.04.3 LTS (jammy). I installed GRASS 8.2.0-1~jammy0 from https://launchpad.net/~ubuntugis/+archive/ubuntu/ppa and ideally need to use GRASS 8.2.0. I also have installed grass-dev and svn. When I try to install the r.clip addon, I get the following error:

g.extension r.clip
/usr/lib/grass82/scripts/g.extension:167: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives
  from distutils.dir_util import copy_tree
Fetching <r.clip> from GRASS GIS Addons repository (be patient)...
svn: E170013: Unable to connect to a repository at URL 'https://github.com/OSGeo/grass-addons/branches/grass8/src/raster/r.clip'
svn: E160013: '/OSGeo/grass-addons/branches/grass8/src/raster/r.clip' path not found
ERROR: GRASS Addons <r.clip> not found

Is there a way to solve this issue?

5
  • This is strange because the URL exists. I have just compiled GRASS GIS 8.2.1 and it works for me. Question: current is 8.3, not 8.2. Any chance for you to avoid the outdated version?
    – markusN
    Commented Jan 14 at 13:20
  • For some reason I haven´t found yet, a code that was provided to me only works with GRASS 8.2 and not with GRASS 8.3. I used GRASS 8.2.0-1~jammy0 because that was the only 8.2* version available in ubuntugis-stable. I was trying to avoid compiling GRASS, but I'll give it a try.
    – Ernesto561
    Commented Jan 15 at 14:43
  • What happens with that code when you use GRASS GIS 8.3? Maybe easy to update?
    – markusN
    Commented Jan 15 at 14:50
  • The code I use uses rgrass to call GRASS from R. I think it's not so easy to update. The error I get is: expected '>' Opening and ending tag mismatch: description line 370 and des Premature end of data in tag flag line 369 Error : 1: expected '>' 2: Opening and ending tag mismatch: description line 370 and des 3: Premature end of data in tag flag line 369 Error in parseGRASS(cmd, legacyExec = legacyExec) : g.region not parsed
    – Ernesto561
    Commented Jan 16 at 14:33
  • I can install addons in GRASS 8.3, but not in 8.2.1 nor in 8.2.2-dev (I compiled them and got the same error). GRASS tmploc/PERMANENT:grass-8.2.1 > g.extension r.accumulate Fetching <r.accumulate> from GRASS GIS Addons repository (be patient)... svn: E170013: Unable to connect to a repository at URL 'github.com/OSGeo/grass-addons/branches/grass8/src/raster/…'
    – Ernesto561
    Commented Jan 16 at 14:41

1 Answer 1

1

Thanks to this answer by Veronica Andreo in the GRASS user list, a workaround is to download the r.clip folder from the GRASS GIS Addons Code Repository and install the extension using the path to the folder.

g.extension extension=r.clip url=path/to/folder/r.clip

This issue is fixed in GRASS 8.3. Github has sunset SVN protocol access and it's not possible to install addons through g.extension in Github in versions lower than 8.3.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.