0

I'm trying to run a Python simulation script in GRASS GIS 8.3.1 on Windows that utilizes the r.futures module. I get the following error when the r.futures.potential command is reached:

ERROR: Rscript required for running r.futures.potential, but not found. Make sure you have R installed and added to the PATH.

I have R 4.3.0 installed, and these four R packages and their dependencies: MumIn, lme4, optparse, rgrass. I've also added the following path to System Variables

"C:\Program Files\R\R-4.3.0"

restarted GRASS GIS, restarted the system but I get the same error message.

1 Answer 1

0

Not sure why it can't find it, but you can execute from the GRASS terminal:

set PATH=%PATH%;C:\Program Files\R\R-4.3.0\bin

This should make Rscript available, but it's adding it to the PATH only for that terminal session.

1
  • I've tried that, it did not work. The program gives the same error message when running the r.futures.potential command. The program works fine for GRASS GIS 8.2 though. Commented Feb 11 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.