0

I am trying to retrieve soil data from the SoilGrid Archive. As I have to work on a 12 Latitude degree X 12 Longitude degree area, and upon multiple chemical/physical property layers, the straightforward solution should be to avoid the SoilGrids viewer and to use the very useful WCS/WMS urls provided by ISRIC (https://maps.isric.org/) into my QGIS 3.28.16 on Windows 10 so that I can easily cut my ROI. However, when importing the layers, I get nothing: in some cases the view is empty and it gives me an error message signaling that the "Data Source has to be fixed". In some other cases the worldwide raster appears as a black square and its properties pane shows that it is without data (empty histogram, no geometric resolution, no dimension). I tried also changing EPSG and changing selected data but no result. This prevent me to save the VRT into Geotiff and store them locally for my work. Am I doing anything wrong or is the platform out of service?

2
  • If you want to import data you should use WCS, WMS gives an image representation only
    – nmtoken
    Jan 22 at 15:42
  • @nmtoken you're perfectly right, thank you for pointing out
    – Edi
    Jan 22 at 16:07

2 Answers 2

1

Its working on my side. Just added a few layers in both WMS and WCS and it seems to be working.

Make sure you use the correct layer link provided in https://maps.isric.org/ for example for SOC (Soil Organic Carbon) link should be: https://maps.isric.org/mapserv?map=/map/soc.map

In QGIS select WMS or WCS depending on your needs. If you select WMS in the "Image Encoding" try PNG it is working for me.

1
  • Thank you @Icalisto for answering. WMS, indeed, still does not work if I use .tiff format, which I need for my workflow
    – Edi
    Jan 23 at 9:54
0

Ok, so I solved the problem noticing a tiny mismatch between the two QGIS versions I am using in this period.

After connecting to WCS, I made it work by giving my QGIS Firenze 3.28.15 the exact area extent BEFORE adding the file into the workspace, rather than AFTER it, otherwise QGIS isn't able to detect the dimensions of the raster and therefore could not save it locally as a .geotiff.

In the meanwhile, I noticed that this passage is not possible in QGIS Bialowieza 3.22.11, where one can only give QGIS the exact area extent AFTER having imported the whole WCS layer into the workspace (which works as well).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.