I can probably sort this out (eventually) but perhaps someone has some magic? After installing GeoServer, when I attempt to start the service:

dfcactual@intrain-home:/usr/share/geoserver/bin $ bash startup.sh

GEOSERVER DATA DIR is /usr/share/geoserver/data_dir

ERROR : Nothing to start, exiting ...

Usage: java -jar $JETTY_HOME/start.jar [options] [properties] [configs]
       java -jar $JETTY_HOME/start.jar --help  # for more information

Context: I am moving a (working) prototype application from a Windows machine to a small farm of Pis. This is slightly out of the mainstream; I am hoping that with a Pi 5 and external SSD the performance will be acceptable.

The sequence of installations has been:

  • Install PostgreSQL
  • Install PostGIS
  • Load selected OpenStreetMap data
  • Confirm Java is present (it's a default installation for Pi-os)
openjdk version "17.0.10" 2024-01-16
OpenJDK Runtime Environment (build 17.0.10+7-Debian-1deb12u1)
OpenJDK 64-Bit Server VM (build 17.0.10+7-Debian-1deb12u1, mixed mode)
  • Because of this issue, I manually installed jetty (sudo apt install jetty9)
Package: jetty9
Version: 9.4.50-4+deb12u2
Priority: optional
Section: java
Maintainer: Debian Java Maintainers <[email protected]>
Installed-Size: 761 kB
Depends: adduser, apache2-utils, default-jre-headless (>= 2:1.8) | java8-runtime-headless, libeclipse-jdt-core-java, libjetty9-extra-java (>= 9.4.50-4+deb12u2), libjetty9-java (>= 9.4.50-4+deb12u2), lsb-base
Recommends: authbind
Homepage: http://www.eclipse.org/jetty/
Download-Size: 272 kB
APT-Manual-Installed: yes
APT-Sources: http://deb.debian.org/debian bookworm/main arm64 Packages
Description: Java servlet engine and webserver
 Jetty is an Open Source HTTP Servlet Server written in 100% Java.
 It is designed to be light weight, high performance, embeddable,
 extensible and flexible, thus making it an ideal platform for serving
 dynamic HTTP requests from any Java application.

This manual installation made no difference.

I have run various options of the "java -jar ..../start.jar" with nothing obvious (to me) reported. I have modified the startup.sh script to spit out some information about the command line it creates: enter image description here

Based on the documentation for Java 17 that says the Marlin rendered needs to be disabled, I have done that in the startup script. (This made no difference in the output).

I will continue to flog this, but has anyone solved this?

2 Answers 2


Okay. Life is good, and GeoServer is running. Based on Ian's suggestion that "this is fixed in recent versions", I downloaded and unpacked geoserver-2.24.x-latest-bin.zip. The server and the admin page now come up. Thanks, Ian. [The version with issues is geoserver-2.24.2-bin.zip, for anyone keeping score].


try from the directory above - so in /usr/share/geoserver run bash ./bin/start.sh - I believe that this is fixed in recent releases.

  • Thank you. May I assume you mean bash, not java in the suggested command line? I didn't get different results starting from the geoserver home.. In my (copy of) the startup.sh script I added the --debug flag and get a lot more information, but it still doesn't tell me what's missing. I intend to try to modify the Main class in the source code so that it spits out the name of the offending module ... however I have a lot to learn before I get that done.
    – dcautley
    Feb 4 at 3:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.