-1

I am attempting to perform a very simple "Select By Location" where I would like to select all the blue circles (buffers of x,y points) that "contain" brown boxes (stations), as per the image attached.

I opened the "Select By Location" tool, input the blue circles as the input features, the brown rectangles as the selecting features, and have tried relationships: "contains", "intersect", "completely contains".

The only way I have successfully produced a selection, is by instead selecting brown boxes within blue circles. This, however, is useless to me, I only tried to see if I could make any selection work. As it did, it suggests to me that there is something wrong with the relationships I am choosing paired with the feature types.

Why am I not getting the selection I expect?

enter image description here

5
  • What is your selection type set to?
    – cl3
    Feb 5 at 20:21
  • It would help if you included the layer list from the TOC and a screenshot of your parameters.
    – Vince
    Feb 5 at 20:48
  • 1
    Are all your data projected in the same coordinate system?
    – Xeppit
    Feb 5 at 21:24
  • @Xeppit you were right! My CRS was not defined for the stations layer. Thank you!
    – Max Duso
    Feb 6 at 23:40
  • You can self-answer the question and mark the question as answered.
    – Xeppit
    Feb 7 at 20:55

1 Answer 1

0

It turns out this was a simple case of one of the layers not having a defined CRS. Defining the CRS of this layer caused "Select by Location" to work as expected.

Thanks @Xeppit for pointing it out.

Not the answer you're looking for? Browse other questions tagged or ask your own question.