1

I got a bunch of LAZ compressed point cloud tiles (over 300). They don't have a projection assigned. I want to assign the correct projection (I know the files are in EPSG:25832) with the action "Assign projection" in QGIS from the toolbox. When I try to run it as batch action, QGIS asks me for the projection of every file. I have set the CRS for every file.

Screenshot of the batch processing tool

This is exactly why I want to assign a projection! Is this a bug or intended behavior? And how can I just assign a projection without getting asked? I don't want to double-click on "EPSG:25832" 300-times.

It seems like QGIS is indexing every point cloud it loads: QGIS processing a point cloud

So assigning a CRS in QGIS doesn't help, as it loads the LAZ-file without CRS anyway.

2
  • Which QGIS Version do you use?
    – Nil
    Commented Feb 8 at 9:42
  • QGIS 3.34.3, installed with OSGeo4W Commented Feb 8 at 9:50

1 Answer 1

1

There is a setting in "CRS and Transforms/CRS Handling/CRS for Layers":

Set it to "Leave as an unknown CRS (take no action)" to prevent QGIS prompting for a CRS selction.

Options for CRS handling

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.