3

In the past, using the OSGEO4W Shell installed as part of QGIS, I was able to run an ogr2ogr command to transfer a feature layer from an ESRI File Geodatabase to a table in PostgreSQL. However, after installing QGIS 3.43, the command no longer works.

After doing some troubleshooting, I noticed that file geodatabase support was not added by default (I figure because openfilegdb is included by default) so I also installed the gdal-filegdb library using the Advanced Install function of the Setup program. That did not fix the problem.

After the export failed in the new version, I uninstalled QGIS 3.43 (including deleting any remaining directories and cleaning the registry) and went back to version 3.28 as the file geodatabase to PostgreSQL export worked in that version. However, after reinstalling QGIS 3.28, and the gdal-filegdb library, it no longer worked in that version either.

The error says the problem occurs in filegdbtable.cpp at line 900, but I am unable to find that file to see what line 900 is.

I have tried two versions of QGIS and installed gdal-filegdb using both the Install from Internet and Download Without Installing options in case the internet install was the issue.

Not sure how to work around this. Has anyone else run into this issue and resolved it?

I am using:

  • Windows Server 2019 Datacenter (this is an AWS WorkSpace)
  • QGIS 3.28.15
  • GDAL 3.8.3 (installed by QGIS)

1 Answer 1

3

Of course it was an ESRI issue. Not an open source one. When the source CSV was imported into the file geodatabase, the date fields were all added using the DATE ONLY format. This format is not supported by GDAL.

I resolved the issue by:

  • Created new DATE fields for all the DATE ONLY fields.
  • Copied the information into the new fields.
  • Deleted the original DATE ONLY fields.
  • Reran the file geodatabase to PostgreSQL command.

Doing the above resolved the issue and the transfer completed without a problem. Wish I had tried that three working days ago.

4
  • So it was an "Esri issue" because the open source utilities didn't support all the available date formats?
    – Vince
    Commented Feb 6 at 3:56
  • 2
    Please make a feature request github.com/OSGeo/gdal/issues and attach a minimal filegdb that triggers the issue. You mean that the issue happens with this driver gdal.org/drivers/vector/filegdb.html? How about OpenFileGDB driver gdal.org/drivers/vector/openfilegdb.html#vector-openfilegdb?
    – user30184
    Commented Feb 6 at 6:52
  • @Vince - it was an ESRI issue because that's a closed format with no documentation
    – Ian Turton
    Commented Feb 6 at 9:20
  • @user30184 - Thank you for the suggestion! The issue happened with both the GDAL filegdb driver and the OpenFileGDB driver as provided by QGIS and OSGeo4W. I will check to see what the latest version is at each link you provided and compare to what QGIS/OSGeo4W provide prior to making a feature request. If QGIS/OSGeo4W are not providing the latest version, and the issue has already been addressed, I will reach out to them to update their respective setups.
    – Mike Smith
    Commented Feb 7 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.