0

I have problems opening a point cloud laz file in QGIS 3.34.0 Prizren on Win 10, PDAL version 2.5.5, Python version 3.9.5. I have older "good" laz-files that I have no trouble opening in QGIS (simply drag and drop), but with newer, "bad" files, I get the error message:

Invalid Data Source : [my_path]/2682500_1250000.laz is not a valid or recognized data source, error: "readers.las: Global encoding WKT flag not set for point format 6 - 10."

For testing purpose, I can share a "good" and a "bad" file: https://drive.switch.ch/index.php/s/ylDsytDAvaB4G5r

I also tried loading via datasource manager, with the same result. I am aware of these solutions: https://gis.stackexchange.com/a/428091/88814

However, I was not able to adapt and run the code accordingly. I used this code in the Python console:

filename = "C:/Users/[path]/laz/bad_file.laz"
f = open(filename, "rb+")
f.seek(6)
f.write(bytes([17, 0, 0, 0]));
f.close()

When I run it, nothing happens. How can I load this file correctly into QGIS?

Running the code above in the Python console does not result in any action: enter image description here


Edit: I tried the solution proposed below using CloudCompare step by step, with no success, I still get the same error message. The file shared by user @Pointdump who proposed the solution opens fine in QGIS, however. So there must be some setting I do wrong? When I save the loaded point cloud from CloudCompare, I get an export dialog. I accept all default options - maybe I have to do some changes? See screenshot:

enter image description here

5
  • Can you contact the data provider and ask them to fix their data?
    – user30184
    Feb 15 at 14:18
  • So you think it's an error in their data? I could try contacting them, however, I should know what exactly is the case.
    – Babel
    Feb 15 at 14:35
  • In asprs.org/wp-content/uploads/2019/03/LAS_1_4_r14.pdf, 2.2, the WKT bit is defined to be mandatory for point types 6-10. The error says that this bit is not set.
    – user30184
    Feb 15 at 14:50
  • @Babel, I'm using CloudCompare v2.11.1 and I don't see the Version and Point Format options you show. Just the "Output LAS/LAZ scale" options.
    – Pointdump
    Feb 16 at 21:53
  • 1
    I use CloudCompare 2.13.0 Kharkiv. When I install CloudCompare 2.11.1, it works! CRS, however, is not recognized, I manually have to set layer CRS to get the point cloud in the correct place. Not sure what additional settings should be done in CloudCompare 2.13.0. I still consider this workaround as a valid (accepted) answer, though. Thanks for your help.
    – Babel
    Feb 16 at 23:10

1 Answer 1

1

I also couldn't load "bad" into QGIS 3.22.16. I drag-n-dropped into and then re-saved "bad" in CloudCompare, compressed to LAZ in Las2Las(this step probably unneccessary), and then it loads into QGIS. Note: Accept defaults in the "Coordinates are too big" dialogue box. When CloudCompare re-saves it will return those original coordinates.

Step 1: Drag-n-drop "bad_file.laz" into CloudCompare. Accept defaults.

Step 2: Select "bad_file-Cloud".

Step 3: File Menu >> Save

Step 4: Accept default file name "bad_file-Cloud.las".

Step 5: Click Save. Accept default of Original Resolution.

enter image description here

enter image description here

enter image description here

9
  • Can you describe a bit more in detail what exactly you did in CloudCompare? If I try it, it is saved as las (instead of laz) file and the resulting file still doesn't open in QGIS. It loads well to CloudCompare, however, as in your first screenshot.
    – Babel
    Feb 15 at 11:54
  • How did you import the bad file? There is the "Coordinnates are too big" waring. I change to "previous input and set shift to 0 to keep coordinate values in EPSG:2056. However, I'm not an expert in CloudCompare and not sure if I do this well.
    – Babel
    Feb 15 at 11:59
  • I edited my answer to add a little detail.
    – Pointdump
    Feb 15 at 14:40
  • 1
    It's showing my "anonymous upload" will take 4-5 hours. You should have it by tomorrow. :)
    – Pointdump
    Feb 15 at 16:29
  • 1
    I had to install the older CloudCompare 2.11.1 instead of the newer 2.13.0 version to get this solution to work.
    – Babel
    Feb 16 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.