1

I have a testfile with 29 hospitals in Germany and their addresses (there are coordinates in the datafile, but I would only like to use this file for testing MMQGIS.) and I would like to use the MMQGIS-Plugin to geocode the adresses, but it only finds 3 out of 29, so that I assume, something is wrong with my data.

Does someone know, what I can do to improve the results?

This is how the testfile looks like: Tabular testfile with 9 columns with the names: Name, City, Postcode, Street, Housenumber, Phone, Latitude, Longitude, StreetAndNumber

The last variable (StreetAndNumber) I created by merging Street and Housenumber, as I use them in the MMQGIS Plugin. This is how I have set the the parameters in the Plugin: enter image description here

5
  • 2
    Why not using the native "Batch Nominatim geocoder" ? The only thing you will need is to create a full address.
    – Taras
    Feb 16 at 12:43
  • @Taras Thanks, that is a nice one! I was already looking out for an option to geocode within a python script! Then this will be my choice when I script!
    – i.i.k.
    Feb 17 at 16:23
  • 1
    Check my Geocoding tutorial: github.com/dubravat/GeoCoding, maybe it will help
    – Taras
    Feb 17 at 17:45
  • 1
    Oh cool, I will definitely check it!
    – i.i.k.
    Feb 17 at 19:02
  • Let me know if you have any questions.
    – Taras
    Feb 17 at 19:41

1 Answer 1

1

The problem was the encoding, probably because the file contains German adresses which include umlauts and ß. My solution was to open the csv-file with Notepadd++, then go to 'Encoding'. It was generally correctly sitting at utf-8, but I needed to change here to 'Convert to ANSI' (the information is from this German youtube channel 'Marshall Mappers': https://www.youtube.com/watch?v=UzHtme9J59g).

Oh, and make sure, that in case you are working on Windows and you may have opened the csv with Excel, that it doesn't delete the first position nulls in the postcodes (e.g. 01234 --> 1234 - this happened to me).

The Plugin now found all of the 29. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.