0

I updated QGIS to the new version via OSGeo4W Setup. Everything worked fine, but when I check plugins, the sagaprovider core plugin shows an error message, that the plugin is defect and the metadata file is missing.

I tried to reinstall QGIS, install qgis-ltr-full meta package and saga 7 / 9 with the OSGeo4W Setup, but nothing fixed the problem.

How can I solve this problem?

1 Answer 1

2

I found a solution!

tl;dr
Got to C:\OSGeo4W\apps\qgis-ltr\python\plugins (or wherever you installed it) and remove the sagaprovider folder.

Since the sagaprovider plugin has been removed earlier, it should not be there anymore. When I started the latest version (3.36.0), the sagaprovider plugin error was not there. So I researched a bit and found out, that this error exists since version 3.30 (https://trac.osgeo.org/osgeo4w/ticket/780) and just in OSGeo4W as it seems.

Then there was a fix, that deletes the old directory when updating (https://github.com/jef-n/OSGeo4W/commit/c44fb7651a5c2edebdb03f8dbb526f6b0dcc4cd5), but just for the latest version, not the ltr.

For using the SAGA tools, you now have to install the Processing Saga NextGen Provider plugin I guess (and don't forget to install SAGA 9 with the OSGeo4W Setup).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.