3

The handy Statistics Panel in QGIS 3.34.3-Prizren (accessible from the summation button) does not seem to recognize NULL values. I have a layer with about 10% NULL values but the Statistics Panel reports "Missing (null) values" as 0. I don't think this is a problem with the specific QGIS version because I've seen this in previous versions but didn't pay much attention.

The "Basic Statistics for fields" Processing Toolbox routine does correctly recognize and report those NULL values.

Any thoughts on why?

Here is a link to sample data that has this problem https://app.box.com/s/73grrnubxghetmkbrv0bzsbht18o1fq1 and below is a screen shot of the table with NULL values and the Statistics Panel showing 0 nulls enter image description here

and below a screenshot of the same shapefile run through the processing Toolbox QDAL routine "Basic Statistics for Fields" which correctly identifies 207 "empty" values. enter image description here

6
  • In the latest version (3.36) the statistic panel "Count (missing)" return an accurate count of null value but empty value are not counted as null. Are you sure that your null value are not in fact empty string or the literal text value 'NULL' ?
    – J.R
    Commented Feb 29 at 15:51
  • @J.R. I upgraded to 3.36 and same result. The field is Real(23,15). The fields have NULL in each cell. If I can find a way I'll share a screen shot showing the table with NULL values and the "Missing (null) values" count of 0 . Commented Feb 29 at 17:48
  • No idea either, it works for me. Is it somehow something to do with the datasource, (shapefile/gpkg/postgres)? Any chance of uploading sample data?
    – she_weeds
    Commented Mar 1 at 2:50
  • I added a link of sample data to the original post that has the problem. This may be operator error but I've used qgis for more than 10 years, so not a newbe. However, there always seems to be some quirk I overlook :( Commented Mar 1 at 16:33
  • 1
    Using your data I get the same result as you (the statistic panel show "Missing (null) values" as 0) , some more testing on other layer show that all numeric field seem to have the same behavior (my previous test was on text field, those seem to work) so it's likely a bug with the statistic panel...I did export your data from shp to gpkg as shp officially doesn't handle null value but the result was the same so it doesn't seem to be related to data format
    – J.R
    Commented Mar 1 at 17:48

1 Answer 1

2

It is actually a bug. A patch that fixes the issue has been merged in the QGIS source code. The bug will no longer occur starting form QGIS versions 3.34.5 and 3.36.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.