I have a workspace that I created maybe a year ago that was an evolution of a workspace I've used since before version 3, where I have 3 maps elements in a layout stacked in an overlay (to keep them centered on each other).

One is always a base image layer locked; another is some layer locked cadastral set (imagine roads over satellite image) and the third (top) is an atlas-controlled layer; say soil chemistry.

When I open this workspace in the 3.34 LTR or the nightly build (3.37) none of the overlays has a transparent background and defaults to white blocking out anything below.

I've turned off the background in the layout item property. I've tried with background enabled (shows whatever color I choose) and get no transparency even if I change the opacity.

I have overlays involved so that the maps center on each other. I tried all the combinations of overlay and not enabled and what not but no different. I have rendering set to normal for the layer. Previously this would just stack the upper layer with no background.

I can get some kind of stacking with a multilply type rendering but the colors get very odd. Am I missing some basic change recently?

  • 1
    I cannot reproduce your error under 3.34 LTR. Could you provide a sample/mockup project for us to check? Commented Mar 7 at 10:09
  • 1
    I can't reproduce it either with the data I have. I agree, I think you need to share more data (at the very least a screenshot). Some questions to narrow it down: does this work with all projects and layers, or only these ones? Does it work if you re-create the structure from scratch? And when was the last QGIS version where this worked for you? I wonder if this is a change in layer styling that didn't carry across properly (saved in a higher version, then opened and saved in a non-compatible lower version, then now opened again in a higher version).
    – she_weeds
    Commented Mar 8 at 7:36
  • Thanks for this suggestion. I am going to try to rebuild the project. It is one I've evolved over >2 years. so It is likely something that fell through the cracks. Also, I should have mentioned I am using an atlas to control layer visibility, though it is only one of the layers that is affected.
    – willemite
    Commented Mar 8 at 21:35
  • 1
    I just recreated a basic version of the layout + atlas that I had (even cheated by copying over to the new workspace and layout figured if it was still an issue I'd go from the ground up). The overlay issue is gone. I guess something crept in there as @she_weeds suggested. really appreciate the help and suggestions.
    – willemite
    Commented Mar 8 at 22:11

1 Answer 1


Thank you to @she_weeds for providing the essential clue. Somehow the project was corrupted, and I need to recreate it. It seems copy-paste from old layouts (into a new workspace) is ok and dragging over layers (into a new workspace) is ok (at least for the few layers I have tried.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.