3

I have a FileGDB with several polygons. When I split them using the Split Features-Tool, they overlap with other polygons within the same layer I did not split.

Here are some screenshots:

Original:

original

Split: the two blue circulated polygons were split. Red are the errors topology checker shows:

split

Only merging some polygons using the merge selected features tool doesn’t create an error/overlap:

merged

Doing the same thing with the same data but in a .gpkg also creates overlaps after splitting the features.

same thing in .gpkg

I'm using QGIS 3.36.2 (but the same problem already appeared in previous versions). The CRS is EPSG:2056 - CH1903+ / LV95. Topology editing is off. It does not make any difference whether I select Allow Overlap or Avoid Overlap on Active Layer.

Does anyone know, how I can prevent polygons from overlapping after splitting (and/or merging) them?

Some sample Data can be downloaded here Google Drive link.

2
  • 1
    Try adding a vertex to both polygons at the blade/edge intersection before splitting. It is likely due because the new vertex location is somewhat rounded (aligned to grid), and therefore it can create a gap or an overlap with the neighbouring polygon
    – JGH
    Commented May 1 at 14:04
  • 2
    When you split a polygon with a drawn or existing line, new vertices are added at each end in the resulting split polys. But no new vertices are added to the adjoining coincident polygon unless you have topological editing on, and that creates a very small overlap or gap, a topological error. The typical solution is to run v.clean after an overlay with a tolerance large enough to fix these. Your data likely was created with a small tolerance; find and use that.
    – John
    Commented May 1 at 17:34

2 Answers 2

5

You need to enable the "Topological editing" feature available in the Snapping toolbar.

1
  • I'm a bit confused by the comment of John, which states, that enabling topological editing may create an overlap. But testing it, there were no more overlaps created when topological editing was on.
    – Motti
    Commented May 6 at 11:05
3

I dont know why you get the overlaps but you can fix them like this:

enter image description here

  1. Union the split and merged layer with itself as input layer, no overlay layer. This will create duplicate overlapping polygons where there are overlaps: enter image description here
  2. Delete duplicate geometries. This will delete one of the duplicate polygons.
  3. Select by expression polygons with low roundness/compactness: ($area*4*pi())/$perimeter^2<0.1. This will be true for the long narrow slivers.
  4. Eliminate selected polygons. I use Merge selected with the largest common boundary.
1
  • 1
    Thanks @BERA for this workaround! I will be very happy to use it if there's no solution for preventing the overlaps to happen.
    – Motti
    Commented May 1 at 7:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.