I am trying to use the "Delete part" tool on a shapefile. While I am starting to use it, an error message shows up : "Could not snap segment. Have you set the tolerance in Settings > Project Properties > General?". I tried to set different tolerances in the snapping options, the error still shows up and I can't delete any part of my polygon. How to fix that?

I use QGis 1.8.0-Lisboa and Windows 7.


  • 2
    what snapping units have you set?are they set in map units or pixels? – vinayan Jan 16 '13 at 2:57

Thanks. I fixed my problem. I had set the snapping unit in map units, I found the right setting for my shapefile in pixels.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.