2

I run difference tool between two area layers.

Sadly, it failed with "Could not add feature with geometry type MultiLineString to layer of type MultiPolygon"

It seems that some of geometries are extremely similar and area degenerates into line.

How can I at least detect in which place it happens? Currently my only idea is to manually split dataset into two, run difference on each, check which fails and repeat. Such binary search will find offending location but it will take hours of manual annoying work. And if I have more places like this...

6
  • Hmm, or maybe I can configure qgis to skip such degenerate cases? Commented May 26 at 5:53
  • 1
    I often get your error when unioning. I sometimes manage to solve it buy Snap to Grid, a small Buffer or by simplifying the geometries, to change the geometries very slightly
    – Bera
    Commented May 26 at 6:50
  • Do the SAGA or Whitebox Difference tools work?
    – John
    Commented May 26 at 15:36
  • @John Have not tried them yet. I was not aware of them. whitebox one is some proprietary software from whiteboxgeo.com/geospatial-software - right? I have not figured yet at all how to get SAGA running. I see say gis.stackexchange.com/questions/344455/… but it is ancient Commented May 27 at 6:37
  • For Whitebox see whiteboxgeo.com/wbw-qgis-plugin For the current way to get SAGA see github.com/north-road/qgis-processing-saga-nextgen Both plugins are reachable via the standard Manage and Install plugins menu option in QGIS. You need to have SAGA and Whitebox Workflows installed on your computer. I think the Whitebox plugin gets that program for you. SAGA can be added as part of the OsGeo4W installer, maybe it's included in the typical Windows install. If you have an older version of QGIS things may be a bit different.
    – John
    Commented May 27 at 17:32

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.