I'm using QGIS 3.34.1-Prizren on macOS 14.

When I use the default XYZ OSM basemap in QGIS on my Retina screen, the roads and labels are all extremely small and pixelated:

  • URL: https://tile.openstreetmap.org/{z}/{x}/{y}.png

QGIS screenshot with default OSM tiles

I tried using a free Retina Tiles account, but the retina tiles are both quite slow (for me in the UK), and also draw text at the same size as the standard OSM ones (meaning: illegibly small).

  • URL: https://retina-tiles.p.rapidapi.com/local/osm@2x/v1/{z}/{x}/{y}.png?rapidapi-key=MY_API_KEY
  • Tile Resolution: High (512x512 / 192 DPI)

QGIS screenshot with Retina Tiles tiles

I have a MapBox account as well, so I tried following these instructions to create a WMTS layer. Unfortunately, while the map is prettier, the text sizes are no more legible:

  • URL: https://api.mapbox.com/styles/v1/mapbox/streets-v9/wmts?access_token=MY_API_TOKEN
  • WMS DPI-Mode: QGIS
  • WMTS server-side tile pixel ratio: High (192 DPI)

QGIS screenshot with Mapbox tiles

I also found this post from 2016 describing the introduction of MapBox HiDPI tiles. So I tried creating an XYZ tile layer using this approach:

  • URL: https://api.mapbox.com/styles/v1/mapbox/streets-v9/tiles/{z}/{x}/{y}@2x?access_token=MY_API_TOKEN
  • Tile Resolution: High (512x512 / 192 DPI)

The layer works well, but the text is, if anything, even smaller:

QGIS screenshot with XYZ MapBox tiles

So I'm stumped. How can I get a basemap with legible street names in QGIS on a Retina screen?

  • 1
  • I had not actually seen those, no. Thanks for the pointers. The first one didn't change anything, but when I set the Magnifier to 200% as suggested in the second one, the results are… better. Not anything like as clear as a web map from Mapbox or Google, but certainly larger than without the magnifier. Anything above 200% starts looking very pixelated. Anyway, if you'd like to provide an answer, I would be happy to accept it.
    – Nick K9
    Commented Jul 6 at 23:40

1 Answer 1


You should use the following settings in QGIS:

And in regard to slow loading tiles: check your dns resolver, it does not seem to support EDNS(0). By that AWS locates you in the US, not UK, resulting in higher latency for the tiles you load as those are served from the US and not EU. If you e.g. are using Cloudflare DNS for resolving (that does not support EDNS(0)), you should change this by e.g. using Google DNS as a resolver or another resolver that does support EDNS.

  • Changing the magnification is indeed the solution. It's not great, but it's definitely better than nothing.
    – Nick K9
    Commented Jul 10 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.