I have a set files that I downloaded with extensions (.e00, .e01, .e02, etc). I have read that these are files used by ARC Info mainly, but I do not have ARC and nor am I really that interested in downloading it. The funnier thing is that I am able to convert a .e00 file in QGIS to a .shp set, but if the file has been broken into many .e0n files, QGIS does not recognize the others and leaves me with only have my shapefile. I have tried taking the other files and copying and pasting their contents to the end of the .e00 file, but this resulted in a very erroneous shape in QGIS. I have been searching for some while now if there is a way to do this with ogr2ogr, but haven't found anything for a set of files like this. I also downloaded e002shp, but had no idea on how to go about using it and didn't find much online for that one. If anyone can tell me any command-line tools I could use (preferably ogr2ogr) or a way to do this in QGIS, I'd gladly appreciate it :)

Actually I'd appreciate any tips, but that is the software which I am more familiar with ;)




What you want is the batch importer by esri import71.exe


Then I guess you would need to convert the arc to shp since you don't have esri with...


Sorry I have not tried the second software. I have autodesk map and arcgis as well as FME and they all convert arcinfo to shape. If this is a one time problem you might find someone (like me) willing to help.

  • I might have to take you up on that offer :). I am on a MAC and it seems most of the software out there for this kind of thing isn't available for MAC users. I found a GDAL package for MAC, but I am not sure how to convert a set of these .e00, .e01, etc files into a set of .shp files. If it was just one .e00 files or at least if they all ended in .e00 then I probably have no trouble as I could just probably use QGIS. – elshae Jan 5 '11 at 15:17
  • My profile contains a skydrive link as my url. I think you can post to that. If not let me know where I can get what you need. I'll getrdun asaic. Gratis – Brad Nesom Jan 5 '11 at 16:46
  • That is very kind of you :). If you take a look at the comment I left for TheSteve0, you'll see that I did get to try Import71 and did not have any luck. I'm actually using the files from this site's FTP ftpserver.ciesin.org/pub/data/China/adm_bnd/CTSAR90.bnd90/… and the file's name is t5190.zip Thanks a bunch :) – elshae Jan 5 '11 at 18:02
  • Sorry for the delay. I put a file on my skydrive for you. Just click my profile an dgo to the url posted on there. The file name is... e00_2_shape_t5190.zip – Brad Nesom Jan 8 '11 at 21:04
  • as a Note: the e00, e01, e02 are split files. The e00 is the base, certain number of bytes (I forget now), then it continuews the export by creating the same size files until all objects are exported. On import the e00 tells the software how many split files there are and it subsequently pulls each one in. – Brad Nesom Jan 9 '11 at 22:13

if you are on windows you can read all about it here http://freegeographytools.com/2007/converting-e00-vector-data-to-shapefiles-a-free-and-fairly-painless-approach

  • Unfortunately I am on a MAC. I saw this this article and thought it was a great walk-through, but it looks like Import71 is a no-go for me :(. Also my issue is not with converting a file with extension .e00 to .shp, but with converting all of the subsequent files .e01, .e02 as it seems this is not a correct format? – elshae Jan 5 '11 at 15:13
  • Yeah I just tried Import71 in my Linux VirtualBox by using WINE. Import71 complains that any file ending in an extension with anything but .e00, is not correctly formatted... – elshae Jan 5 '11 at 17:57
  • the other files should automagically get picked up as they are the continuation of the first file - think of it as a multipart zip file (loosely analogous) – TheSteve0 Jan 6 '11 at 7:02
  • Ok, it seems I'm having issues with the Import71 software itself. I just ran it again on a windows machine and I'm getting the message "This file cannot be accessed. Make sure you have security privileges on the drive" when if fact I do have full-permissions on my files and folders. This happened to me on both the windows machine and the Linux where I ran it with WINE... – elshae Jan 6 '11 at 21:47
ogr2ogr t5190.shp t5190.e00

Should do the trick.

Sometimes you could try combining the files prior to running ogr2ogr.

cat filename.e0* >filename-merged.e00

Other possibilities: there is a module in saga gis (Import ESRI E00 File) that can do the trick. From that link it seems that also grass has a function to import these files.

  • ` ./e00conv ../t5190/t5190.e01 ../t5190/t5191.e00` ERROR 4: ../t5190/t5190.e01 is not a valid E00 file. Not sure if this is what I was supposed to do, but this was my error. Actually I'll be honest, I do not know what is e00conv purpose with these files... – elshae Jan 6 '11 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.