To convert the raster into a shapefile I use raster->conversion->polygonize but QGIS doesn't open the new layer overlayed the first (the raster) but reflected above it.

below the original raster layer above it the reflected output

I read this question Polygonize problem but it is incomplete and there are no solutions. I've changed CRS I used EPSG:4326 for both or User Defined but nothing...

I've changed image format, .tiff .jpg, nothing!

This is the original .bmp file:original .bmp file

These are the metadata of the shapefile:

General: Storage type of this layer: ESRI Shapefile Source for this layer: gisprovavector Geometry type of the features in this layer: Polygon The number of features in this layer: 2 Editing capabilities of this layer: Add Features, Delete Features, Change Attribute Values, Add Attributes, Delete Attributes, Create Spatial Index, Fast Access to Features at ID, Change Geometries Extents: In layer spatial reference system units : xMin,yMin 0,0 : xMax,yMax 962,500 Layer Spatial Reference System: +proj=longlat +ellps=WGS72 +towgs84=0,0,1.9,0,0,0.814,-0.38 +no_defs

I use QGIS 1.8.0 in Windows XP!

  • 2
    Does this question provide any clues? gis.stackexchange.com/questions/4801 – whuber Jul 2 '12 at 19:27
  • 2
    I second @whuber's suggestion to check the prior question. To directly address your problem, we need more information. It would help to know the file format of your raster, the projection of the raster, and the projection that your shapefile is going to be. It would be most helpful if you would edit your question and include the contents of the world file for your raster, and potentially before and after screenshots of your data. – Get Spatial Jul 4 '12 at 9:11
  • @ underdark [marked as duplicate] I read this question Polygonize problem but it is incomplete and there were no solutions until I posted one. This is why I posted this question I tried to be more clear and put more information and images as request from previous users.I've no more things to add so I will not edit it if you think is a duplicate delete it. Thanks for your help! Best regards! – G M Jan 25 '13 at 21:04
  • You're right, this question contains more information. The answer stays same. I turned it around and closed the older one now. Thanks for posting an answer. – underdark Jan 25 '13 at 22:00

In fact the same thing happened to me I tried to use the polygonize algorithm in Windows and Linux with QGIS 1.7 and 1.8. Probably there is a little bug in GdalTools that inverts some values in the output file and so the output is reflected "mirror like". However I resolved it georeferencing the raster image BEFORE using the polygonize tool. Raster -> Georeferencer ->Georeferencer. This for the moment is the only solution I've found!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.