3

I was given a folder of .sid, .sdw, and .sid.aux.xml files to use as tiles on our map. I'm pretty sure I can use ImageMosaic for this and have followed the doc at http://docs.geoserver.org/stable/en/user/tutorials/image_mosaic_plugin/imagemosaic.html. When I get to the step to add a Store and click save, I get the error "Could not list layers for this store, an error occurred retrieving them: Argument "value" should not be null." What can I do to fix this? Thanks!

  • did you follow docs.geoserver.org/stable/en/user/data/raster/…? – Ian Turton Jan 21 '13 at 15:09
  • Yes, but after I was done installing the native libraries, I didn't see all of the Raster Data Sources it says I should have. I don't have JP2MrSID or MrSID. – Bl8rchk Jan 21 '13 at 16:11
  • sounds like a problem installing the native libs then, what does gdalinfo --formats give you? – Ian Turton Jan 21 '13 at 16:34
  • MrSID is in there (I can't paste the whole list in here)... ... MrSID (ro): Multi-resolution Seamless Image Database (MrSID) JP2MrSID (ro): MrSID JPEG2000 ... – Bl8rchk Jan 21 '13 at 16:43
  • 1
    I have figured out the problem. I have OpenGeo Suite which I assumed set up gdal the same but it doesn't. It says I have to enable MrSID on install. Do you know if I can change that after install? I don't want to reinstall and lose everything if I don't have to. – Bl8rchk Jan 21 '13 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.