I am using join field tool to join table (info tables/.dbf) to one shapefile.

I am trying to use ModelBuilder, as there are around 100 tables (each with 5 columns X 50-150 rows), each has to be joined with one shapefile (3 column X ~2 million rows). After the join new shapefile has to be saved as respective field table’s name.

  • 1
    Perhaps you can post a picture of your model so far. I would expect to see Iterate Files, Parse Path, Join File and Table To Table tools in it.
    – PolyGeo
    Commented Jan 22, 2013 at 9:36
  • Thanks for your comments. As a new user, I am not allowed to upload image here. Please try this link (docs.google.com/drawings/d/…)
    – Ankit
    Commented Jan 25, 2013 at 9:41
  • Are you expecting to get 100 output shapefiles each with a subset of the 2 million feature shapefile?
    – PolyGeo
    Commented Jan 25, 2013 at 10:27
  • yes. that right.
    – Ankit
    Commented Jan 25, 2013 at 12:30

2 Answers 2


I just created and successfully tested the model illustrated below.

enter image description here

Most settings should be evident from the illustration but things to watch out for are:

  • Add Join must have Keep All Target Features unchecked
  • Copy Features needs Output Feature Class set to %Input Workspace%\%Name%FC
  • There is a Precondition set between the output of Copy Features and Remove Join

I created this model using ArcGIS 10.1 SP1 but I would expect it to work on 10.0 and any later version.

  • Thanks PolyGeo. I am trying this now. Will get back to you.
    – Ankit
    Commented Jan 26, 2013 at 11:28
  • Once again thanks for your help so far. Much appreciated. Your instructions are so clear that any amateur i.e. someone like me can easily do it. It seems, somewhere there is still a small hitch. I tried as you suggested but the model shows error at 'Copy features'. I should mention here that, I have enabled 'overwrite the outputs' in Geoprocessing options. Here are some of screenshots for your reference (docs.google.com/folder/d/0B0cX3mRNOMfJb1MtS0xZOWZKSFE/edit). Thanks.
    – Ankit
    Commented Jan 26, 2013 at 18:52
  • It looks like you got past your first error by setting a value for the %Input Workspace% variable but then tried to create a shapefile name containing a $ symbol which caused the second error.
    – PolyGeo
    Commented Jan 26, 2013 at 22:31
  • Hi PolyGeo, Thanks very much for all your help. After renaming the tables (removing '$'), the model seems to be working fine. Your help greatly appreciated. I also checked your website. Let's keep in touch and let's look for opportunities for common interests. Best wishes.
    – Ankit
    Commented Jan 28, 2013 at 9:10
  • If this worked for for you don't forget to hit the Accept button it:-)
    – PolyGeo
    Commented Jan 28, 2013 at 22:35

Traditionally this is done in 3 steps: MakeFeatureLayer & AddJoin, then CopyFeatures to persist the joined table to a new output.

At 10.0 there is a 'convenience tool' called Join Field that does this in 1 step. It updates the input table. Sounds like in your case you'll want to copy the input first.

  • Thanks for your comments. As a new user, I am not allowed to upload image here. Please try this link (docs.google.com/drawings/d/…)
    – Ankit
    Commented Jan 25, 2013 at 9:45
  • I was amused to see which method was described as traditional in this answer. Workstation's JOINITEMS, from which I believe Join Field can trace its lineage, was in ARC/INFO by about 1987 at latest.
    – PolyGeo
    Commented Feb 25, 2013 at 9:29
  • you're old enough to see the old become the new again. :/
    – gotchula
    Commented Feb 27, 2013 at 5:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.