3

I'm trying to calculate isotherms following the istructions showed in the post on OSGeo blog (http://blog.opengeo.org/2013/01/10/chaining-rendering-transformations-in-geoserver/)

I'm using GeoServer 2.2.3 on a Windows 7 machine (8 Gbyte RAM, biprocessor)

I've a shapefile with points and temperature and I'm trying to use the Meteo-1.sld

Using the layer in preview

http://:8080/geoserver/CesareWorkspace/wms?service=WMS&version=1.1.0&request=GetMap&layers=CesareWorkspace:CentralineTemperature-01-01-2001&styles=&bbox=318287.0,4880823.0,515945.0,5142603.0&width=386&height=512&srs=EPSG:32632&format=application/openlayers

it works fine but when I try to use le Meteo-1.sld

http://:8080/geoserver/CesareWorkspace/wms?service=WMS&version=1.1.0&request=GetMap&layers=CesareWorkspace:CentralineTemperature-01-01-2001&styles=&bbox=318287.0,4880823.0,515945.0,5142603.0&width=386&height=512&srs=EPSG:32632&format=application/openlayers&STYLES=Meteo-1

the map is white. It seems that there are no errors in the log.

When I try to use the Barnes Surface WPS directy (gs.BarnesSurface), I obtain a black tiff ....

At the following link https://www.dropbox.com/sh/fmbdhzwp5mobpcq/lf43d3SykM there are:

  • data.zip --> the shapefile I'm using
  • Meteo-1.sld --> the sld I'm using
  • geoserver.log --> geoserver log

Could someone tell me which configurations I've to use in the sld for my data? Or give me a sample data and a sld that works?

2

I worked a little bit on this issue and now I'm able to obtain something that works (still not a final work but it's fine ....).

At the following link https://www.dropbox.com/sh/fmbdhzwp5mobpcq/lf43d3SykM there are:

TemperatureBand.sld --> SLD to generate a temperature band surface
Isotherm.sld --> SLD ti generate isotherm from the temperature band surface
TemeperatureBand-Isothem --> SLD "all in one"

It seems better: try to creare a Group Layer using the point, the surface and the isothems and it looks better now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.