2

I'm working with a set of shapefiles and have some problems with the "align" of them in QGIS when I load Openlayers to reference some points. OLs has an straight horizontal baseline but the shapefiles have a slighted inclination.

I tried changing CRS-datum etc with no luck.

However, when I open the same shapefiles in ArcGIS Desktop they have a straight base line similar to that of OL in QGIS. Any ideas of the problem? If there is any problem.

https://picasaweb.google.com/117688487090958721662/QGIS

8
  • yep, project CRS and layer the same, google mercator. Same shp opens perfectly straight in ArcGis without any modification Jan 28, 2013 at 16:57
  • This is the original .prj PROJCS["NAD_1983_Lambert_Conformal_Conic",GEOGCS["GCS_North_American_1983",DATUM["D_North_American_1983",SPHEROID["GRS_1980",6378137.0,298.257222101]],PRIMEM["Greenwich",0.0],UNIT["Degree",0.0174532925199433]],PROJECTION["Lambert_Conformal_Conic"],PARAMETER["False_Easting",0.0],PARAMETER["False_Northing",0.0],PARAMETER["Central_Meridian",-95.0],PARAMETER["Standard_Parallel_1",49.0],PARAMETER["Standard_Parallel_2",77.0],PARAMETER["Latitude_Of_Origin",49.0],UNIT["Meter",1.0]] Jan 28, 2013 at 17:08
  • I tried using that projection but didn't work. Checked in and out "on the fly" neither. So I tried in Arc Gis and worked. Is there a bug in QGIS/openlayers? Jan 28, 2013 at 17:11
  • the layer disappears:( and if I change the project CRS to NAD I get an error from openlayer. Ok The system is saying to avoid long comments but I cannot move to chat Jan 28, 2013 at 17:15
  • Try selecting "Set Project CRS from Layer" on the OCM Landscape layer.
    – Aaron
    Jan 28, 2013 at 17:17

2 Answers 2

4

Can you try reprojecting the shapefile (ie saving it again with a different CRS)? The one you posted is Lambert Conformal Conic, with a central meridian of 95 degrees. That pretty much matches what your image shows. I believe it is this projection (or at least this is close enough).

For example, you could use OGR: ogr2ogr -t_srs EPSG:4326 -s_srs EPSG:42304 reprojectedshapefile.shp originalshapefile.shp

Note, I didn't read it too closely, but this old stack exchange topic may be helpful too: Is there projection issue with Natural Resources Canada (NRC) Canada Atlas hydrology data?

2
  • Ok. Txs I never used OGR I'll get a try:) Jan 28, 2013 at 17:33
  • Thank you very much!!! I worked perfect!!! 100s of hours working with that!!! Jan 28, 2013 at 17:44
0

It's possible that the line strings need more vertices to "peg" the lines to the ground at more frequent intervals. You could try "Densify geometries" from under the Vector menu to add vertices and see if this improves things. N.

1
  • No. It wasn't that. Txs for your effort. G Jan 28, 2013 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.