I am using opengeo suite with openlayers and google maps as my base layer. I have points in a postgis database that I am using to generate wms tiles. I'm pretty sure I have the projections right because the points are spot-on for the most part. I run into problems when I get in to the last two zoom levels when the google maps turn into that 3d view in some areas. The markers then show up as in the wrong places and if I pan the map they pan at a different pace. If I don't let the map zoom in that far, its fine, but we have to be able to zoom in closer. Can I turn off the 3d view on google maps or adjust the projection?

1 Answer 1


"Whenever you add a Google Maps layer to your OpenLayers map, it adds a reference to the Google Maps mapObject that it is using to request the Google Maps imagery. By calling the setTilt method on the map object, we can disable 45 degree imagery for all Google Maps layers, like so:


Add this line after you add the layer to the map.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.