2

I am trying to add a ring in a feature in a shapefile. This feature is a single part feature but has already a few rings. When I try to add the new ring, I have the error message : "The inserted Ring is not contained in a feature". I tried to modify my snapping options thinking that the problem came from this setting, but I didn't have any luck.

Does anybody know how I can fix this problem?

I use QGis 1.8.0-Lisboa and Windows 7.

Thanks

  • are creating a inner ring or deleting from a single part polygon? – Mapperz Jan 28 '13 at 21:19
  • I am creating an inner ring – Bap Jan 28 '13 at 21:53
1

When adding a new ring, if the ring outline intersect any of the existing rings, you would get that error message. Here i tried to create the red ring, but it is intersecting an existing ring. Also check if there are any unwanted snapping to edges setup.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.