Just getting started with GeoServer and already running into problems. When I click on Layer Preview and view any of the preloaded data in OpenLayers (or any other format) it is just blank and has the missing image icon where the data should be. One interesting thing is that I could click randomly in the blank map and see attributes of selected polygons appear so I think the data is partially loaded. Example screenshot.

I've installed it on multiple machines and I am getting the same exact problem. I have connected my own data through PostGIS but I got the same result. That is why I am assuming it is user error. Anyone have any ideas?

3 Answers 3


I just started using GeoServer today and i ran into the same issue. Found this conversation: http://comments.gmane.org/gmane.comp.gis.geoserver.user/35646

Seems that you're using JRE7 just as i do. There's something way bad with this JRE. Try using JRE or more preferably JDK 6.x

Haven't tried out yet, just an assumption on the culprit.

  • Now i'm sure that was the problem. Reinstalled GeoServer with jdk1.6.0_37's JRE and everything is OK.
    – SandorRacz
    Jan 31, 2013 at 15:36
  • Thanks! This worked. I uninstalled Java and GeoServer, then downloaded the JDK from here (Warning you have to register with Oracle before you can download). Then I reinstalled GeoServer this time pointing to the newly downloaded JDK and everything worked!
    – Taylor H.
    Jan 31, 2013 at 17:22

I've had the same problem on GeoServer (Win7 x64), however the latest of java RE7 (update 21) seems to solve my problem, I'm using GeoServer 2.3.0 and so far it fixed the missing image on layer preview.

Also I want to let you know that I didn't have to reinstall Geoserver. On the other hand you can change the path to the java RE that GeoServer points. Go to GeoServer/bin/ folder and edit the .bat files, both for the startup and shutdown, you can point to the JRE version you have installed or the one it works best for you.

Latest JRE7 update: JRE7 u21 (you must Accept License Agreement)

So far this update works pretty well with GS 2.3.0

Cheers. Alberto.


The supported versions of JRE for 'Geoserver 2.2.5/2.3.0' is 'jre-6u37'...I personally had the same problem at first but this after reinstalling the mentioned JRE versions it worked...

All you have to do is to mention the installed jre path during Geoserver installation..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.